Update HS3 Z-Wave Plug-in

Z-NET requires HS3 Z-Wave plug-in v3.0.0.196 (or higher). Download and install the new plug-in from your HS3 updater. Check the Beta section of the updater (at the bottom of the list) to find the latest Z-Wave plug-in.

Still need help? Contact Us Contact Us