Update HS3 Z-Wave Plug-in

SmartStick+ requires HS3 Z-Wave plug-in v3.0.1.11 (or higher). Download and install the new plug-in from your HS3 updater.

Still need help? Contact Us Contact Us